Reverb Repair

May 1, 2010

gp0510_fix3676THE REVERB ON MY FENDER VIBRO-King amp was working fine on a gig, and then suddenly stopped working after I had the amp in my car’s trunk for a 50-mile drive. I’ve checked the connections to the tank and chassis and they’re fine, the tubes are all glowing, and the ’verb still crashes when you rock the amp back and forth. What else should I look for? —AT, via email

When reverbs fail, it is almost always a bad cable or a bad connection at one of the RCA plugs. If you have another Fender amp with reverb, you can plug its RCA connectors into the Vibro-King and see if the other pan/cables work. If you still don’t hear reverb, that pretty much rules out the pan and cables.

There are two parts to a reverb system: the reverb driver circuit and the reverb recovery circuit. To test the drive circuit, unplug the pan from the amp and hook a speaker to the jack instead. This is the jack that goes to the reverb driver transformer. (Remove the 6L6 output tubes so you don’t hear signal coming from the amp’s speakers.) You should be able to play the guitar through the reverb channel and hear it through the speaker you connected. This will verify that the driver portion of your reverb is working. If there’s no sound it could be a bad reverb driver tube or some other component.




If the drive circuit is malfunctioning, check the following:
gp0510_fix36721. Try changing the first 12AX7 (the one at the far right when viewing from the back, Fig. 1). This is the preamp tube that is driving the EL84 reverb driver, and if one of its two triode stages has failed, the reverb won’t function.









gp0510_fix36742. If that doesn’t fix things, check the reverb driver transformer to make sure the primary is not open. An easy way to do that is to check pin 7 on the plate of the EL84 reverb driver tube. That is where the transformer primary is connected. With the amp “on,” you should see a meter reading of 420 volts or so. This will confirm that the primary is not open (Figures 2a and 2b).








gp0510_fix36683. Next, check the secondary for continuity using an ohmmeter. With the amp off and unplugged from AC, disconnect the RCA connector from the amp chassis and connect a meter (set for the lowest ohms range.) You should measure very low resistance, somewhere around one ohm (1Ω) or less (Fig. 3).









gp0510_fix36754. Another cause could be a failed component connecting to the EL84 (the third tube from the right in Fig. 1), such as a cathode resistor or bypass cap. These go to pin 3 of the EL84.

5. Check for a burned-out screen resistor; this is the resistor that feeds pin 9 of the EL84 socket (Fig. 4).

If none of these steps uncovers the problem, you’ll need to test the reverb recovery circuit.

Start by re-installing the output tubes. Disconnect the RCA plugs that connect the pan to the chassis, and then, using an adapter, plug your guitar into the reverb return RCA jack; this is the RCA jack that goes to pin 7 of the second 12AX7. When you turn up the reverb Mix knob on your Vibro-King, you should hear guitar signal coming through the speakers. If there’s no sound, then the recovery circuit is malfunctioning and you should try replacing the second 12AX7.

Important: Caution should be taken when working on tube amplifiers. High voltages are present that are potentially lethal, even when the amplifier is unplugged. Therefore, servicing should be performed only by a qualified technician.

Keep up-to-date on the latest news
Get our Free Newsletter Here!


comments powered by Disqus

Reader Poll

Best amp from the 1960s?

See results without voting »