ChannelStrip 2.1 Update Adds Pro Tools 7 Support

November 11, 2005

Users should note that ChannelStrip version 2.0.3 f13 is not compatible with Pro Tools 7, and should update to the new version before or at the same time as running the Pro Tools 7 update to avoid any interruption in the operation of ChannelStrip. The 2.1 f02 update is compatible with previous versions of Pro Tools (6.x), and can be safely installed by any OS X based customer.

For more information, visit their web site at

Keep up-to-date on the latest news
Get our Free Newsletter Here!


comments powered by Disqus

Reader Poll

Best amp from the 1960s?

See results without voting »